Why should you update your PHP version?

Posted by: absolute

News And Insights » Why should you update your PHP version?

If your store is using Magento 1 and running on PHP 5.6, your site will be vulnerable as from the 30th December 2018. PHP provides security support for various versions of PHP, and version 5.6 is the latest to have its support cease as from the end of 2018. Learn what PHP is.

What happens if you don’t update your PHP?

As a result, sites running on PHP 5.6 will become increasingly vulnerable. They’ll be more intensively targeted by robots in the knowledge that security support will no longer exist, and their efforts to compromise sites are no longer policed.

In short, remaining on PHP 5.6 will become a security threat that will only get worse with time. Plus, PHP 7.2 also offers appreciable performance improvements with up to 3x more requests handled per second and it’s up to 250% faster.

How easy is it to update your PHP version on Magento 1?

Your Magento website can be easily upgraded to run on PHP 7.2 using either a Magento support patch or preferably, as part of the recent Magento 1.9.4.0 release which has PHP 7.2 support built-in. Plus, you’ll benefit from all the other fixes and enhancements that come with the release.

It's important that you maintain your online store’s security in light of the news that PHP 5.6 will cease to be secure from the end of Dec 2018. As a trusted Magento Business Solution Partner, Absolute will manage the upgrade for you and perform any remedial work that may come from the upgrade. You’ll know you’re in safe hands with a team of in-house Magento certified developers who are committed to keeping your site safe, secure and compliant.

Need to upgrade your PHP version, and soon? Get in touch with us so we can get the ball rolling

Some of the brands we work with...